[SEV-3] Settlement File Delay

Incident Report for Togetherpay

Resolved

All regular settlement files and merchant settlement files are now available. This incident is resolved.
Posted Oct 31, 2025 - 11:51 EDT

Investigating

Regular settlement files and merchant settlement files will not be available by 9:00 a.m. eastern this morning. Comprehensive reports were delivered by ProPay and are already available. We will send an update as soon as we have more information and when the settlement files are available.
Posted Oct 31, 2025 - 08:48 EDT
This incident affected: Togetherpay Client Application (File Import Process - Internal) and Togetherpay API - Production (File Import Process - External).