[SEV-3] Intermittent Processing Issues

Incident Report for Togetherpay

Resolved

ProPay implemented a fix which appears to have fixed the problem. The last transaction to timeout was at 4:59 p.m. eastern. Processing is back to normal.
Posted Nov 18, 2025 - 17:47 EST

Investigating

A small percentage of Togetherpay transactions are timing out. ProPay was notified and is looking into the situation. As soon as additional information is known, we will let you know.
Posted Nov 18, 2025 - 16:38 EST
This incident affected: Togetherpay API - Production (Transaction Processing).