[SEV-3] ProPay Chargeback Issue

Incident Report for Togetherpay

Resolved

ProPay confirmed the chargeback issue has been resolved. They are still assessing the scope and impact of the issue.
We will share additional details as they become available from ProPay.
Posted May 01, 2026 - 12:09 EDT

Investigating

ProPay has identified an ongoing issue impacting chargebacks. An internal change made late last week caused disruptions that prevented some chargebacks from being initiated.

The full scope and impact are still being assessed. ProPay’s teams are actively working to resolve the issue and restore normal processing.

We will provide updates as more information becomes available.
Posted May 01, 2026 - 08:33 EDT
This incident affected: Togetherpay API - Production (Transaction Processing).