[SEV-3] Togetherpay - Intermittent Processing Issues | Canada

Incident Report for Togetherpay

Resolved

ProPay has implemented a fix and is will continue to monitor the results. At this time this incident is resolved.
Posted Nov 24, 2025 - 15:54 EST

Identified

ProPay has identified the issue and is actively working to implement a fix.
Posted Nov 24, 2025 - 14:05 EST

Investigating

ProPay is aware of an issue that may impact the ability to process transactions for Canadian merchants. They are actively working to resolve the issue. As soon as additional information is known, we will let you know.
Posted Nov 24, 2025 - 12:04 EST
This incident affected: Togetherpay API - Production (Transaction Processing, Payment Tokenization, Merchant Endpoints, ProPay Production Environment).