[SEV-3] Intermittent Processing Issues

Incident Report for Togetherpay

Resolved

Processing has returned to normal. This incident is involved.
Posted Oct 15, 2025 - 15:19 EDT

Monitoring

Between 2:00pm and 2:30pm Eastern Time, some transactions timed out due to connectivity issues.
ProPay has identified and resolved the issue, and processing has remained stable since.
Posted Oct 15, 2025 - 15:09 EDT

Identified

ProPay is aware of the issue and is working with teams to resolve.
It appears processing is back to normal. We will continue to monitor the situation until a permanent resolution is confirmed.
Posted Oct 15, 2025 - 14:52 EDT

Investigating

We are aware of an issue that is preventing some transactions from processing. We are currently investigating the cause of the issue. We will share more information as it becomes available.
Posted Oct 15, 2025 - 14:33 EDT
This incident affected: Togetherpay API - Production (Transaction Processing, Payment Tokenization, Merchant Endpoints, ProPay Production Environment).