[SEV-3] Togetherpay Sandbox/Integration Unavailable

Incident Report for Togetherpay

Resolved

ProPay concluded their maintenance - both sandbox and integration are now available. This incident is resolved.
Posted Jul 14, 2025 - 15:22 EDT

Monitoring

Both sandbox and integration are currently unavailable. ProPay informed us they will be down until they are able to apply necessary security updates - ETA unknown.

As soon as we have more information and/or when the environments are back up and running, we will let you know.
Posted Jul 14, 2025 - 13:41 EDT
This incident affected: Togetherpay API - Testing Environments (Integration Test Environment, Sandbox Test Environment, ProPay Testing Environments).