[SEV-3] Settlement/Comprehensive File Delay - 3/9/2025

Incident Report for Togetherpay

Resolved

All regular settlement files, comprehensive reports and merchant settlement file are now available. This incident is resolved.
Posted Mar 09, 2025 - 10:00 EDT

Investigating

Regular settlement files, comprehensive reports and merchant settlement files will not be available by 9:00 a.m. eastern this morning. We will send an update as soon as we have more information and when the files are available.
Posted Mar 09, 2025 - 08:55 EDT
This incident affected: Togetherpay Client Application (File Import Process - Internal) and Togetherpay API - Production (File Import Process - External).