[SEV-3] Togetherpay - Account Boarding Issue
Incident Report for Togetherpay
Resolved
ProPay's third party service provider implemented a fix, restoring identity validation services for ProPay account boarding. Automated account review and approval is operational again. This incident is resolved.
Posted Jan 09, 2024 - 17:24 EST
Identified
ProPay identified the source of the issue as one of their third party service providers used for ID verification. Teams are working to restore account onboarding services. As more is known, we will let you know. If you have an immediate onboarding need that requires extra attention, reach out to the Payments Team (payments@togetherwork.com) with specifics.
Posted Jan 09, 2024 - 14:10 EST
Investigating
ProPay is aware of an issue that is preventing new accounts from being boarded. They are actively working to resolve the issue. As soon as additional information is known, we will let you know.
Posted Jan 09, 2024 - 11:09 EST
This incident affected: Togetherpay API - Production (ProPay Production Environment).