[SEV-4] Togetherpay - Intermittent Processing Issues - Discover
Incident Report for Togetherpay
Resolved
Elevated decline/error rates for Discover charges occurred earlier today from 2:08 p.m. - 4:52 p.m. eastern as a result of an outage impacting the Discover card network. Success rates have returned to normal. We will continue to monitor but are considering this incident resolved.
Posted Feb 06, 2023 - 17:29 EST
Investigating
We are aware of an issue that is preventing some Discover transactions from successfully processing. While we haven't received anything official from ProPay, we have received notification from other processors confirming the Discover network is affected. While most Discover transactions are declining or erroring, some are successfully processing. Non-Discover cards are not affected. As soon as additional information is known, we will let you know.
Posted Feb 06, 2023 - 15:35 EST
This incident affected: Togetherpay API - Production (Transaction Processing, Payment Tokenization, ProPay Production Environment).