[SEV-3] Togetherpay - Account Boarding Issue
Incident Report for Togetherpay
Resolved
ProPay identified and corrected the issue affecting merchant onboarding. This incident is now resolved.
Posted Mar 19, 2024 - 08:54 EDT
Update
ProPay is aware of an issue that is preventing new accounts from being boarded. They are actively working to resolve the issue. As soon as additional information is known, we will let you know.
Posted Mar 18, 2024 - 14:36 EDT
Investigating
ProPay is aware of an issue that is preventing new accounts from being boarded. They are actively working to resolve the issue. As soon as additional information is known, we will let you know.
Posted Mar 18, 2024 - 14:28 EDT
This incident affected: Togetherpay API - Production (Merchant Endpoints, ProPay Production Environment).