[SEV-4] Intermittent Processing Issues
Incident Report for Togetherpay
Resolved
ProPay's fix for their Visa decline code situation is not expected to roll until late November. In the meantime, Togetherwork found a way to pinpoint which of ProPay's error responses are true errors and which of their error responses are actual declines. Togetherpay rolled some code this afternoon which is functioning as intended. This incident is resolved.
Posted Oct 25, 2021 - 14:44 EDT
Monitoring
ProPay is working to fix how they interpret the decline codes from Visa. However, they do not expect the errors to be resolved until next week.

The cause of the transaction errors is ProPay’s system is not interpreting the decline codes correctly which throws back an error. These transactions would have failed anyway, but because of the interpretation issues at ProPay, an error is returned instead of a decline.

We will leave this issue as monitoring until a fix is fully implemented.
Posted Oct 15, 2021 - 16:39 EDT
Identified
ProPay believes the Visa processing issue is related to a release made by their upstream processor. The release changed how ProPay receives response codes, specifically for Visa transactions. This update caused their system to have issues interpreting the decline response. ProPay is working to release a fix that will address the issues with Visa transactions.

We will continue to provide updates until the issue is resolved.
Posted Oct 15, 2021 - 15:26 EDT
Update
We are in contact with ProPay to investigate further. As soon as additional information is known, we will let you know.
Posted Oct 15, 2021 - 14:39 EDT
Investigating
We are aware of an issue that is preventing some transactions from being processed. We believe the errors may be isolated to Visa transactions. Our teams are investigating the issue and will provide updates until the situation is resolved.
Posted Oct 15, 2021 - 10:56 EDT
This incident affected: Togetherpay API - Production (Transaction Processing, ProPay Production Environment).